aboutsummaryrefslogtreecommitdiff
path: root/hw/i386/xen/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'hw/i386/xen/meson.build')
-rw-r--r--hw/i386/xen/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/hw/i386/xen/meson.build b/hw/i386/xen/meson.build
index 3dc4c4f106..3f0df8bc07 100644
--- a/hw/i386/xen/meson.build
+++ b/hw/i386/xen/meson.build
@@ -1,8 +1,10 @@
i386_ss.add(when: 'CONFIG_XEN', if_true: files(
- 'xen-hvm.c',
'xen_apic.c',
'xen_pvdevice.c',
))
+i386_ss.add(when: ['CONFIG_XEN', xen], if_true: files(
+ 'xen-hvm.c',
+))
i386_ss.add(when: 'CONFIG_XEN_BUS', if_true: files(
'xen_platform.c',