aboutsummaryrefslogtreecommitdiff
path: root/hw/core/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'hw/core/meson.build')
-rw-r--r--hw/core/meson.build12
1 files changed, 10 insertions, 2 deletions
diff --git a/hw/core/meson.build b/hw/core/meson.build
index c9fe6441d9..7ec7bb93d5 100644
--- a/hw/core/meson.build
+++ b/hw/core/meson.build
@@ -1,7 +1,6 @@
# core qdev-related obj files, also used by *-user and unit tests
hwcore_ss.add(files(
'bus.c',
- 'hotplug.c',
'qdev-properties.c',
'qdev.c',
'reset.c',
@@ -11,8 +10,17 @@ hwcore_ss.add(files(
'irq.c',
'clock.c',
'qdev-clock.c',
- 'qdev-hotplug.c',
))
+if have_system
+ hwcore_ss.add(files(
+ 'hotplug.c',
+ 'qdev-hotplug.c',
+ ))
+else
+ hwcore_ss.add(files(
+ 'hotplug-stubs.c',
+ ))
+endif
common_ss.add(files('cpu-common.c'))
softmmu_ss.add(when: 'CONFIG_FITLOADER', if_true: files('loader-fit.c'))