aboutsummaryrefslogtreecommitdiff
path: root/contrib/vhost-user-gpu/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/vhost-user-gpu/meson.build')
-rw-r--r--contrib/vhost-user-gpu/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/contrib/vhost-user-gpu/meson.build b/contrib/vhost-user-gpu/meson.build
new file mode 100644
index 0000000000..6c1459f54a
--- /dev/null
+++ b/contrib/vhost-user-gpu/meson.build
@@ -0,0 +1,13 @@
+if 'CONFIG_TOOLS' in config_host and 'CONFIG_VIRGL' in config_host \
+ and 'CONFIG_GBM' in config_host and 'CONFIG_LINUX' in config_host
+ executable('vhost-user-gpu', files('vhost-user-gpu.c', 'virgl.c', 'vugbm.c'),
+ link_with: libvhost_user,
+ dependencies: [qemuutil, pixman, gbm, virgl],
+ install: true,
+ install_dir: get_option('libexecdir'))
+
+ configure_file(input: '50-qemu-gpu.json.in',
+ output: '50-qemu-gpu.json',
+ configuration: config_host,
+ install_dir: config_host['qemu_datadir'] / 'vhost-user')
+endif