aboutsummaryrefslogtreecommitdiff
path: root/block/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'block/meson.build')
-rw-r--r--block/meson.build51
1 files changed, 35 insertions, 16 deletions
diff --git a/block/meson.build b/block/meson.build
index 90dc9983e5..8a1ce58c9c 100644
--- a/block/meson.build
+++ b/block/meson.build
@@ -45,25 +45,44 @@ block_ss.add(files(
softmmu_ss.add(when: 'CONFIG_TCG', if_true: files('blkreplay.c'))
-block_ss.add(when: 'CONFIG_QCOW1', if_true: files('qcow.c'))
-block_ss.add(when: 'CONFIG_VDI', if_true: files('vdi.c'))
-block_ss.add(when: 'CONFIG_CLOOP', if_true: files('cloop.c'))
-block_ss.add(when: 'CONFIG_BOCHS', if_true: files('bochs.c'))
-block_ss.add(when: 'CONFIG_VVFAT', if_true: files('vvfat.c'))
-block_ss.add(when: 'CONFIG_DMG', if_true: files('dmg.c'))
-block_ss.add(when: 'CONFIG_QED', if_true: files(
- 'qed-check.c',
- 'qed-cluster.c',
- 'qed-l2-cache.c',
- 'qed-table.c',
- 'qed.c',
-))
-block_ss.add(when: 'CONFIG_PARALLELS', if_true: files('parallels.c', 'parallels-ext.c'))
+if get_option('qcow1').allowed()
+ block_ss.add(files('qcow.c'))
+endif
+if get_option('vdi').allowed()
+ block_ss.add(files('vdi.c'))
+endif
+if get_option('cloop').allowed()
+ block_ss.add(files('cloop.c'))
+endif
+if get_option('bochs').allowed()
+ block_ss.add(files('bochs.c'))
+endif
+if get_option('vvfat').allowed()
+ block_ss.add(files('vvfat.c'))
+endif
+if get_option('dmg').allowed()
+ block_ss.add(files('dmg.c'))
+endif
+if get_option('qed').allowed()
+ block_ss.add(files(
+ 'qed-check.c',
+ 'qed-cluster.c',
+ 'qed-l2-cache.c',
+ 'qed-table.c',
+ 'qed.c',
+ ))
+endif
+if get_option('parallels').allowed()
+ block_ss.add(files('parallels.c', 'parallels-ext.c'))
+endif
+
block_ss.add(when: 'CONFIG_WIN32', if_true: files('file-win32.c', 'win32-aio.c'))
block_ss.add(when: 'CONFIG_POSIX', if_true: [files('file-posix.c'), coref, iokit])
block_ss.add(when: libiscsi, if_true: files('iscsi-opts.c'))
block_ss.add(when: 'CONFIG_LINUX', if_true: files('nvme.c'))
-block_ss.add(when: 'CONFIG_REPLICATION', if_true: files('replication.c'))
+if not get_option('replication').disabled()
+ block_ss.add(files('replication.c'))
+endif
block_ss.add(when: libaio, if_true: files('linux-aio.c'))
block_ss.add(when: linux_io_uring, if_true: files('io_uring.c'))
@@ -89,7 +108,7 @@ foreach m : [
endforeach
# those are not exactly regular block modules, so treat them apart
-if 'CONFIG_DMG' in config_host
+if get_option('dmg').allowed()
foreach m : [
[liblzfse, 'dmg-lzfse', liblzfse, 'dmg-lzfse.c'],
[libbzip2, 'dmg-bz2', [glib, libbzip2], 'dmg-bz2.c']