aboutsummaryrefslogtreecommitdiff
path: root/backends/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'backends/meson.build')
-rw-r--r--backends/meson.build10
1 files changed, 7 insertions, 3 deletions
diff --git a/backends/meson.build b/backends/meson.build
index 9a5cea480d..8b2b111497 100644
--- a/backends/meson.build
+++ b/backends/meson.build
@@ -10,9 +10,13 @@ system_ss.add([files(
'confidential-guest-support.c',
), numa])
-system_ss.add(when: 'CONFIG_POSIX', if_true: files('rng-random.c'))
-system_ss.add(when: 'CONFIG_POSIX', if_true: files('hostmem-file.c'))
-system_ss.add(when: 'CONFIG_LINUX', if_true: files('hostmem-memfd.c'))
+if host_os != 'windows'
+ system_ss.add(files('rng-random.c'))
+ system_ss.add(files('hostmem-file.c'))
+endif
+if host_os == 'linux'
+ system_ss.add(files('hostmem-memfd.c'))
+endif
if keyutils.found()
system_ss.add(keyutils, files('cryptodev-lkcf.c'))
endif