aboutsummaryrefslogtreecommitdiff
path: root/ui/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2021-10-10 00:16:57 +0400
committerMarc-André Lureau <marcandre.lureau@redhat.com>2021-12-21 10:50:22 +0400
commit99997823bbbd23aa0cce42e03b49fd8a57222e5e (patch)
tree42969eeb9548b76cd9cdced065c2abccf2b5d189 /ui/meson.build
parent142ca628a733d0f523ad2b6713a22945e505f061 (diff)
ui/dbus: add p2p=on/off option
Add an option to use direct connections instead of via the bus. Clients are accepted with QMP add_client. This allows to provide the D-Bus display without a bus. It also simplifies the testing setup (some CI have issues to setup a D-Bus bus in a container). Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Acked-by: Gerd Hoffmann <kraxel@redhat.com>
Diffstat (limited to 'ui/meson.build')
-rw-r--r--ui/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/ui/meson.build b/ui/meson.build
index 6270aa768b..80f21704ad 100644
--- a/ui/meson.build
+++ b/ui/meson.build
@@ -14,6 +14,9 @@ softmmu_ss.add(files(
'qemu-pixman.c',
'util.c',
))
+if dbus_display
+ softmmu_ss.add(files('dbus-module.c'))
+endif
softmmu_ss.add([spice_headers, files('spice-module.c')])
softmmu_ss.add(when: spice_protocol, if_true: files('vdagent.c'))