aboutsummaryrefslogtreecommitdiff
path: root/ui/meson.build
diff options
context:
space:
mode:
authorGerd Hoffmann <kraxel@redhat.com>2021-05-19 07:39:40 +0200
committerGerd Hoffmann <kraxel@redhat.com>2021-05-21 09:42:44 +0200
commitd11ebe2ca257769337118d3b0ff3f76ea4928018 (patch)
treecea1b41349fd55cc587af847863d6e43833c1a05 /ui/meson.build
parent5f692f57843d33aa32dc58de76286a7a86ada4c1 (diff)
ui/gtk: add clipboard support
This patch adds clipboard support to the qemu gtk ui. Signed-off-by: Gerd Hoffmann <kraxel@redhat.com> Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com> Message-id: 20210519053940.1888907-1-kraxel@redhat.com Message-Id: <20210519053940.1888907-10-kraxel@redhat.com>
Diffstat (limited to 'ui/meson.build')
-rw-r--r--ui/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/ui/meson.build b/ui/meson.build
index f37ef882e0..b5aed14886 100644
--- a/ui/meson.build
+++ b/ui/meson.build
@@ -65,7 +65,7 @@ if gtk.found()
softmmu_ss.add(when: 'CONFIG_WIN32', if_true: files('win32-kbd-hook.c'))
gtk_ss = ss.source_set()
- gtk_ss.add(gtk, vte, pixman, files('gtk.c'))
+ gtk_ss.add(gtk, vte, pixman, files('gtk.c', 'gtk-clipboard.c'))
gtk_ss.add(when: x11, if_true: files('x_keymap.c'))
gtk_ss.add(when: [opengl, 'CONFIG_OPENGL'], if_true: files('gtk-gl-area.c'))
gtk_ss.add(when: [x11, opengl, 'CONFIG_OPENGL'], if_true: files('gtk-egl.c'))