aboutsummaryrefslogtreecommitdiff
path: root/tests/unit/meson.build
diff options
context:
space:
mode:
authorYanan Wang <wangyanan55@huawei.com>2021-10-26 11:46:59 +0800
committerPhilippe Mathieu-Daudé <philmd@redhat.com>2021-11-01 19:44:11 +0100
commit9e8e393bb795ff6c6963c47376369e90b1d40467 (patch)
tree8760e4b16229c6c7a73af0677b5d32bbc5728a1c /tests/unit/meson.build
parent86ce2d28fa09d15547b5cabdc264cadfb53a848c (diff)
tests/unit: Add an unit test for smp parsing
Now that we have a generic parser smp_parse(), let's add an unit test for the code. All possible valid/invalid SMP configurations that the user can specify are covered. Signed-off-by: Yanan Wang <wangyanan55@huawei.com> Reviewed-by: Andrew Jones <drjones@redhat.com> Tested-by: Philippe Mathieu-Daudé <philmd@redhat.com> Message-Id: <20211026034659.22040-3-wangyanan55@huawei.com> Acked-by: Eduardo Habkost <ehabkost@redhat.com> Message-Id: <bfed7144-af86-7098-e7a6-731ff13c2cf7@huawei.com> [PMD: Squashed format string fixup from Yanan Wang] Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com>
Diffstat (limited to 'tests/unit/meson.build')
-rw-r--r--tests/unit/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/unit/meson.build b/tests/unit/meson.build
index 5ac2d9e943..acac3622ed 100644
--- a/tests/unit/meson.build
+++ b/tests/unit/meson.build
@@ -46,6 +46,7 @@ tests = {
'test-uuid': [],
'ptimer-test': ['ptimer-test-stubs.c', meson.project_source_root() / 'hw/core/ptimer.c'],
'test-qapi-util': [],
+ 'test-smp-parse': [qom, meson.project_source_root() / 'hw/core/machine-smp.c'],
}
if have_system or have_tools