aboutsummaryrefslogtreecommitdiff
path: root/tests/qtest/meson.build
diff options
context:
space:
mode:
authorThomas Huth <thuth@redhat.com>2021-08-11 11:47:05 +0200
committerThomas Huth <thuth@redhat.com>2021-08-11 13:39:50 +0200
commitcc1838c25d55e7f478cd493431679337e24e1b72 (patch)
treece0f93b8f5cc6f2aaa049656a6d7524ec571546f /tests/qtest/meson.build
parenta1f0f36838caa8d8dbde4b5be2f889942fb66fd4 (diff)
storage-daemon: Add missing build dependency to the vhost-user-blk-test
vhost-user-blk-test needs the qemu-storage-daemon, otherwise it currently hangs. So make sure that we build the daemon before running the tests. Message-Id: <20210811094705.131314-1-thuth@redhat.com> Tested-by: Alexander Bulekov <alxndr@bu.edu> Signed-off-by: Thomas Huth <thuth@redhat.com>
Diffstat (limited to 'tests/qtest/meson.build')
-rw-r--r--tests/qtest/meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/tests/qtest/meson.build b/tests/qtest/meson.build
index e22a0792c5..2bc3efd49f 100644
--- a/tests/qtest/meson.build
+++ b/tests/qtest/meson.build
@@ -276,8 +276,11 @@ foreach dir : target_dirs
endif
qtest_env.set('G_TEST_DBUS_DAEMON', meson.source_root() / 'tests/dbus-vmstate-daemon.sh')
qtest_env.set('QTEST_QEMU_BINARY', './qemu-system-' + target_base)
- qtest_env.set('QTEST_QEMU_STORAGE_DAEMON_BINARY', './storage-daemon/qemu-storage-daemon')
-
+ if have_tools and have_vhost_user_blk_server
+ qtest_env.set('QTEST_QEMU_STORAGE_DAEMON_BINARY', './storage-daemon/qemu-storage-daemon')
+ test_deps += [qsd]
+ endif
+
foreach test : target_qtests
# Executables are shared across targets, declare them only the first time we
# encounter them