aboutsummaryrefslogtreecommitdiff
path: root/tests/qtest/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2022-10-06 17:05:13 +0400
committerThomas Huth <thuth@redhat.com>2022-10-12 08:43:40 +0200
commitf57559891d9527627747d36cbdc7def0e278c5ff (patch)
tree1df73c577251c3d95022c5809485e6c630ae6870 /tests/qtest/meson.build
parent0793fe014c4fc8649288044cd81024482b197cfc (diff)
qtest: start a VNC test
This is some of the simplest test we could perform, it simply connects to the VNC server via passed-in socket FDs and checks the connection can be established. Another series will make this test work on Windows as well. As always, more tests can be added later! :) Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Message-Id: <20221006130513.2683873-1-marcandre.lureau@redhat.com> Signed-off-by: Thomas Huth <thuth@redhat.com>
Diffstat (limited to 'tests/qtest/meson.build')
-rw-r--r--tests/qtest/meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/qtest/meson.build b/tests/qtest/meson.build
index 455f1bbb7e..c07a5b1a5f 100644
--- a/tests/qtest/meson.build
+++ b/tests/qtest/meson.build
@@ -306,8 +306,14 @@ qtests = {
'vmgenid-test': files('boot-sector.c', 'acpi-utils.c'),
}
+gvnc = dependency('gvnc-1.0', required: false)
+if gvnc.found()
+ qtests += {'vnc-display-test': [gvnc]}
+ qtests_generic += [ 'vnc-display-test' ]
+endif
+
if dbus_display
-qtests += {'dbus-display-test': [dbus_display1, gio]}
+ qtests += {'dbus-display-test': [dbus_display1, gio]}
endif
qtest_executables = {}