aboutsummaryrefslogtreecommitdiff
path: root/tests/qtest/meson.build
diff options
context:
space:
mode:
authorThomas Huth <thuth@redhat.com>2022-04-14 13:46:55 +0200
committerThomas Huth <thuth@redhat.com>2022-04-20 08:54:39 +0200
commit2051658061a102f49e68419a0052991222157b56 (patch)
tree022ff86a0d893c21aeae0bcea5c11cabad6decd5 /tests/qtest/meson.build
parentb0dd0a3d74e9ed9532bd4a7724bdafffe7509462 (diff)
tests/qtest: Enable more tests for the "mipsel" target
Allow the same set of tests for all MIPS targets, so that "mipsel" now gets some additional test coverage, too. While we're at it, simplify the definitions for qtests_mips64 and qtests_mips64el. Message-Id: <20220414114655.604391-1-thuth@redhat.com> Signed-off-by: Thomas Huth <thuth@redhat.com>
Diffstat (limited to 'tests/qtest/meson.build')
-rw-r--r--tests/qtest/meson.build14
1 files changed, 3 insertions, 11 deletions
diff --git a/tests/qtest/meson.build b/tests/qtest/meson.build
index d25f82bb5a..1709fc6ccb 100644
--- a/tests/qtest/meson.build
+++ b/tests/qtest/meson.build
@@ -143,17 +143,9 @@ qtests_mips = \
(config_all_devices.has_key('CONFIG_ISA_TESTDEV') ? ['endianness-test'] : []) + \
(config_all_devices.has_key('CONFIG_VGA') ? ['display-vga-test'] : [])
-qtests_mips64 = \
- ['test-filter-mirror', 'test-filter-redirector'] + \
- (slirp.found() ? ['test-netfilter'] : []) + \
- (config_all_devices.has_key('CONFIG_ISA_TESTDEV') ? ['endianness-test'] : []) + \
- (config_all_devices.has_key('CONFIG_VGA') ? ['display-vga-test'] : [])
-
-qtests_mips64el = \
- ['test-filter-mirror', 'test-filter-redirector'] + \
- (slirp.found() ? ['test-netfilter'] : []) + \
- (config_all_devices.has_key('CONFIG_ISA_TESTDEV') ? ['endianness-test'] : []) + \
- (config_all_devices.has_key('CONFIG_VGA') ? ['display-vga-test'] : [])
+qtests_mipsel = qtests_mips
+qtests_mips64 = qtests_mips
+qtests_mips64el = qtests_mips
qtests_ppc = \
['test-filter-mirror', 'test-filter-redirector'] + \