aboutsummaryrefslogtreecommitdiff
path: root/tests/qtest/libqos/meson.build
diff options
context:
space:
mode:
authorBibo Mao <maobibo@loongson.cn>2024-05-28 16:20:53 +0800
committerSong Gao <gaosong@loongson.cn>2024-06-06 11:56:36 +0800
commitfe43cc5bde32d8bba930242f34ad55002ea4819e (patch)
tree042041a382d6ca5c09a42c4f3d57128a51b235a3 /tests/qtest/libqos/meson.build
parentdb2feb2df8d19592c9859efb3f682404e0052957 (diff)
tests/libqos: Add loongarch virt machine node
Add loongarch virt machine to the graph. It is a modified copy of the existing riscv virtmachine in riscv-virt-machine.c It contains a generic-pcihost controller, and an extra function loongarch_config_qpci_bus() to configure GPEX pci host controller information, such as ecam and pio_base addresses. Also hotplug handle checking about TYPE_VIRTIO_IOMMU_PCI device is added on loongarch virt machine, since virtio_mmu_pci device requires it. Signed-off-by: Bibo Mao <maobibo@loongson.cn> Acked-by: Thomas Huth <thuth@redhat.com> Message-Id: <20240528082053.938564-1-maobibo@loongson.cn> Signed-off-by: Song Gao <gaosong@loongson.cn>
Diffstat (limited to 'tests/qtest/libqos/meson.build')
-rw-r--r--tests/qtest/libqos/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/qtest/libqos/meson.build b/tests/qtest/libqos/meson.build
index 3aed6efcb8..558eb4c24b 100644
--- a/tests/qtest/libqos/meson.build
+++ b/tests/qtest/libqos/meson.build
@@ -61,6 +61,7 @@ libqos_srcs = files(
'ppc64_pseries-machine.c',
'x86_64_pc-machine.c',
'riscv-virt-machine.c',
+ 'loongarch-virt-machine.c',
)
if have_virtfs