aboutsummaryrefslogtreecommitdiff
path: root/tests/qapi-schema/meson.build
diff options
context:
space:
mode:
authorMarkus Armbruster <armbru@redhat.com>2024-02-16 15:58:25 +0100
committerMarkus Armbruster <armbru@redhat.com>2024-02-26 10:43:56 +0100
commit976474fdb2706626987677990e22f10d71918902 (patch)
tree2e7de2904ad1d08e60a1ec719a4314c92d021996 /tests/qapi-schema/meson.build
parent3cee17e739d54cca5b6c6975f335a2115e5dbbbd (diff)
tests/qapi-schema: Fix test 'QAPI rST doc'
The test compares Sphinx plain-text output against a golden reference. To work on Windows hosts, it filters out carriage returns in both files. Unfortunately, the filter doesn't work: it creates an empty file. Comparing empty files always succeeds. Fix the filter, and update the golden reference to current Sphinx output. Signed-off-by: Markus Armbruster <armbru@redhat.com> Message-ID: <20240216145841.2099240-2-armbru@redhat.com> Reviewed-by: Daniel P. Berrangé <berrange@redhat.com>
Diffstat (limited to 'tests/qapi-schema/meson.build')
-rw-r--r--tests/qapi-schema/meson.build10
1 files changed, 6 insertions, 4 deletions
diff --git a/tests/qapi-schema/meson.build b/tests/qapi-schema/meson.build
index af085f745d..44a9385563 100644
--- a/tests/qapi-schema/meson.build
+++ b/tests/qapi-schema/meson.build
@@ -273,15 +273,17 @@ if build_docs
output: ['doc-good.txt.nocr'],
input: qapi_doc_out[0],
build_by_default: true,
- command: [remove_cr, '@INPUT@'],
- capture: true)
+ command: [remove_cr],
+ capture: true,
+ feed: true)
qapi_doc_ref_nocr = custom_target('QAPI rST doc reference newline-sanitized',
output: ['doc-good.ref.nocr'],
input: files('doc-good.txt'),
build_by_default: true,
- command: [remove_cr, '@INPUT@'],
- capture: true)
+ command: [remove_cr],
+ capture: true,
+ feed: true)
test('QAPI rST doc', diff, args: ['-u', qapi_doc_ref_nocr[0], qapi_doc_out_nocr[0]],
suite: ['qapi-schema', 'qapi-doc'])