aboutsummaryrefslogtreecommitdiff
path: root/tests/qapi-schema/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2021-08-04 12:31:01 +0400
committerMarkus Armbruster <armbru@redhat.com>2021-08-26 13:53:56 +0200
commit5d83b9a130690f879d5f33e991beabe69cb88bc8 (patch)
treeec68563193b1bbaafb4614a08e15845d33f8d7d9 /tests/qapi-schema/meson.build
parentd806f89f87152def5f422e946c84948831615236 (diff)
qapi: replace if condition list with dict {'all': [...]}
Replace the simple list sugar form with a recursive structure that will accept other operators in the following commits (all, any or not). Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Message-Id: <20210804083105.97531-7-marcandre.lureau@redhat.com> Reviewed-by: Markus Armbruster <armbru@redhat.com> [Accidental code motion undone. Degenerate :forms: comment dropped. Helper _check_if() moved. Error messages tweaked. ui.json updated. Accidental changes to qapi-schema-test.json dropped.] Signed-off-by: Markus Armbruster <armbru@redhat.com>
Diffstat (limited to 'tests/qapi-schema/meson.build')
-rw-r--r--tests/qapi-schema/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/qapi-schema/meson.build b/tests/qapi-schema/meson.build
index b8de58116a..4697c070bc 100644
--- a/tests/qapi-schema/meson.build
+++ b/tests/qapi-schema/meson.build
@@ -37,8 +37,11 @@ schemas = [
'bad-data.json',
'bad-ident.json',
'bad-if.json',
+ 'bad-if-all.json',
'bad-if-empty.json',
'bad-if-empty-list.json',
+ 'bad-if-key.json',
+ 'bad-if-keys.json',
'bad-if-list.json',
'bad-type-bool.json',
'bad-type-dict.json',