aboutsummaryrefslogtreecommitdiff
path: root/tests/plugin/meson.build
diff options
context:
space:
mode:
authorGreg Manning <gmanning@rapitasystems.com>2023-11-20 15:08:23 +0000
committerAlex Bennée <alex.bennee@linaro.org>2023-11-23 14:10:04 +0000
commit4789f9d3a16dbd8139d935ec3c5008d0fbd40f88 (patch)
tree0db5984832d2fb1f1fe36b2335b01c66b85ee7e8 /tests/plugin/meson.build
parent8e721c327778948bdbd2076a417e8ccc67525ae7 (diff)
plugins: fix win plugin tests on cross compile
Resolves: https://gitlab.com/qemu-project/qemu/-/issues/1972 Cross compile gcc is more picky about argument order than msys. Changed the meson command to take the (now renamed) libqemu_plugin_api.a as a lib, rather than an object. This puts it in the right place on both native and cross compile gcc commands Reenable plugins on crossbuilds Signed-off-by: Greg Manning <gmanning@rapitasystems.com> Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org> Message-Id: <20231109124326.21106-2-gmanning@rapitasystems.com> Signed-off-by: Alex Bennée <alex.bennee@linaro.org> Message-Id: <20231120150833.2552739-5-alex.bennee@linaro.org>
Diffstat (limited to 'tests/plugin/meson.build')
-rw-r--r--tests/plugin/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/plugin/meson.build b/tests/plugin/meson.build
index 528bb9d86c..28a929dbcc 100644
--- a/tests/plugin/meson.build
+++ b/tests/plugin/meson.build
@@ -4,7 +4,8 @@ if get_option('plugins')
if targetos == 'windows'
t += shared_module(i, files(i + '.c') + '../../contrib/plugins/win32_linker.c',
include_directories: '../../include/qemu',
- objects: [win32_qemu_plugin_api_lib],
+ link_depends: [win32_qemu_plugin_api_lib],
+ link_args: ['-Lplugins', '-lqemu_plugin_api'],
dependencies: glib)
else