aboutsummaryrefslogtreecommitdiff
path: root/tcg/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2024-05-24 10:54:50 +0200
committerPaolo Bonzini <pbonzini@redhat.com>2024-05-25 13:28:02 +0200
commit61306156d976b1235e26dc1658ccaae2170ce185 (patch)
tree424fd3f1c4fc6c357333fb0b41e57633912571da /tcg/meson.build
parent2bfd3c4860a0058ff65a5da16f4d2609ac70b580 (diff)
tcg: include dependencies in static_library()
This ensures that for example libffi can be reached even if it is not in /usr/include. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'tcg/meson.build')
-rw-r--r--tcg/meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/tcg/meson.build b/tcg/meson.build
index 8251589fd4..ffbe754d8b 100644
--- a/tcg/meson.build
+++ b/tcg/meson.build
@@ -32,19 +32,19 @@ tcg_ss = tcg_ss.apply({})
libtcg_user = static_library('tcg_user',
tcg_ss.sources() + genh,
name_suffix: 'fa',
+ dependencies: tcg_ss.dependencies(),
c_args: '-DCONFIG_USER_ONLY',
build_by_default: false)
-tcg_user = declare_dependency(link_with: libtcg_user,
- dependencies: tcg_ss.dependencies())
+tcg_user = declare_dependency(link_with: libtcg_user)
user_ss.add(tcg_user)
libtcg_system = static_library('tcg_system',
tcg_ss.sources() + genh,
name_suffix: 'fa',
+ dependencies: tcg_ss.dependencies(),
c_args: '-DCONFIG_SOFTMMU',
build_by_default: false)
-tcg_system = declare_dependency(link_with: libtcg_system,
- dependencies: tcg_ss.dependencies())
+tcg_system = declare_dependency(link_with: libtcg_system)
system_ss.add(tcg_system)