aboutsummaryrefslogtreecommitdiff
path: root/tcg/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2023-08-30 11:52:43 +0200
committerPaolo Bonzini <pbonzini@redhat.com>2023-12-31 09:11:28 +0100
commit1220f5813a7e1c4ff9cf7ffa189f979be3801044 (patch)
treed536697049a5b1380fab0e04fdb6a6feaba3ee92 /tcg/meson.build
parentdc4954943d3adc82c4052aed592f2dc5a14c3fc7 (diff)
meson: remove config_targetos
config_targetos is now empty and can be removed; its use in sourcesets that do not involve target-specific files can be replaced with an empty dictionary. In fact, at this point *all* sourcesets that do not involve target-specific files are just glorified mutable arrays. Enforce that they never test for symbols in "when:" by computing the set of files without "strict: false". Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'tcg/meson.build')
-rw-r--r--tcg/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/tcg/meson.build b/tcg/meson.build
index 895a11d3fa..5afdec1e1a 100644
--- a/tcg/meson.build
+++ b/tcg/meson.build
@@ -22,7 +22,7 @@ if get_option('tcg_interpreter')
tcg_ss.add(files('tci.c'))
endif
-tcg_ss = tcg_ss.apply(config_targetos, strict: false)
+tcg_ss = tcg_ss.apply({})
libtcg_user = static_library('tcg_user',
tcg_ss.sources() + genh,