aboutsummaryrefslogtreecommitdiff
path: root/target/ppc/meson.build
diff options
context:
space:
mode:
authorBruno Larsen (billionai) <bruno.larsen@eldorado.org.br>2021-05-25 08:53:54 -0300
committerDavid Gibson <david@gibson.dropbear.id.au>2021-06-03 13:22:06 +1000
commit8033fb3fbf1165569cfcdeac7fab257bb72740f5 (patch)
treea67a82924e1076f279259912baa5094640ea5c8d /target/ppc/meson.build
parent2b44e21949352ffa045399c56a6ddde86eeb2ec6 (diff)
target/ppc: created tcg-stub.c file
Created a file with stubs needed to compile disabling TCG. *_ppc_opcodes were created to make cpu_init.c have a few less ifdefs, since they are not needed. softmmu_resize_hpt_* have to be created because the compiler can't automatically know they aren't used, but they should never be reached. Signed-off-by: Bruno Larsen (billionai) <bruno.larsen@eldorado.org.br> Message-Id: <20210525115355.8254-4-bruno.larsen@eldorado.org.br> Signed-off-by: David Gibson <david@gibson.dropbear.id.au>
Diffstat (limited to 'target/ppc/meson.build')
-rw-r--r--target/ppc/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/ppc/meson.build b/target/ppc/meson.build
index d1aa7d5d39..848e625302 100644
--- a/target/ppc/meson.build
+++ b/target/ppc/meson.build
@@ -28,6 +28,10 @@ ppc_softmmu_ss.add(files(
'mmu_helper.c',
'monitor.c',
))
+ppc_softmmu_ss.add(when: 'CONFIG_TCG', if_false: files(
+ 'tcg-stub.c'
+))
+
ppc_softmmu_ss.add(when: 'TARGET_PPC64', if_true: files(
'compat.c',
'mmu-book3s-v3.c',