aboutsummaryrefslogtreecommitdiff
path: root/target/ppc/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé <philmd@linaro.org>2023-06-26 16:01:00 +0200
committerDaniel Henrique Barboza <danielhb413@gmail.com>2023-07-07 04:18:26 -0300
commit28eafc1270c5878a2f2538b8050443f88c5c9282 (patch)
tree3af4148a183f3cc3c360664ca2afbc59d82ce2bd /target/ppc/meson.build
parent2ad2e113deb5663e69a05dd6922cbfc6d7ea34d3 (diff)
target/ppc: Only generate decodetree files when TCG is enabled
No need to generate TCG-specific decodetree files when TCG is disabled. Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org> Reviewed-by: Greg Kurz <groug@kaod.org> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Message-ID: <20230626140100.67941-1-philmd@linaro.org> Signed-off-by: Daniel Henrique Barboza <danielhb413@gmail.com>
Diffstat (limited to 'target/ppc/meson.build')
-rw-r--r--target/ppc/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/ppc/meson.build b/target/ppc/meson.build
index a69f174f41..4c2635039e 100644
--- a/target/ppc/meson.build
+++ b/target/ppc/meson.build
@@ -28,7 +28,7 @@ gen = [
extra_args: ['--static-decode=decode_insn64',
'--insnwidth=64']),
]
-ppc_ss.add(gen)
+ppc_ss.add(when: 'CONFIG_TCG', if_true: gen)
ppc_ss.add(when: 'CONFIG_KVM', if_true: files('kvm.c'), if_false: files('kvm-stub.c'))
ppc_ss.add(when: 'CONFIG_USER_ONLY', if_true: files('user_only_helper.c'))