aboutsummaryrefslogtreecommitdiff
path: root/target/mips/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé <f4bug@amsat.org>2021-01-16 16:32:06 +0100
committerPhilippe Mathieu-Daudé <f4bug@amsat.org>2021-05-02 16:49:34 +0200
commitfed50ffd5ce4b03f94036232c613b2ca8fba06eb (patch)
tree53110af34aca6e21976db92993bb1cca05c17798 /target/mips/meson.build
parent830a72301c35548907ff05399a99f34dab9c867d (diff)
target/mips: Move msa_reset() to new source file
mips_cpu_reset() is used by all accelerators, and calls msa_reset(), which is defined in msa_helper.c. Beside msa_reset(), the rest of msa_helper.c is only useful to the TCG accelerator. To be able to restrict this helper file to TCG, we need to move msa_reset() out of it. Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Message-Id: <20210428170410.479308-4-f4bug@amsat.org>
Diffstat (limited to 'target/mips/meson.build')
-rw-r--r--target/mips/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/mips/meson.build b/target/mips/meson.build
index 5fcb211ca9..daf5f1d55b 100644
--- a/target/mips/meson.build
+++ b/target/mips/meson.build
@@ -11,6 +11,7 @@ mips_ss.add(files(
'cpu.c',
'fpu.c',
'gdbstub.c',
+ 'msa.c',
))
mips_tcg_ss = ss.source_set()
mips_tcg_ss.add(gen)