aboutsummaryrefslogtreecommitdiff
path: root/target/mips/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé <f4bug@amsat.org>2021-02-17 21:23:49 +0100
committerPhilippe Mathieu-Daudé <f4bug@amsat.org>2021-03-13 23:43:02 +0100
commitb24db6fcd4063db6d001e958b28bfc2dadb249d9 (patch)
treec5ce1ff3164ee94bc48d8dc94c819c331cc3d18e /target/mips/meson.build
parentfe35ea94838d8faba749ecfd49256f59e5fe0653 (diff)
target/mips: Extract MXU code to new mxu_translate.c file
Extract 1600+ lines from the big translate.c into a new file. Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Message-Id: <20210226093111.3865906-14-f4bug@amsat.org>
Diffstat (limited to 'target/mips/meson.build')
-rw-r--r--target/mips/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/mips/meson.build b/target/mips/meson.build
index 53580633ce..4a951e522d 100644
--- a/target/mips/meson.build
+++ b/target/mips/meson.build
@@ -24,6 +24,10 @@ mips_tcg_ss.add(files(
'translate.c',
'translate_addr_const.c',
))
+mips_tcg_ss.add(when: 'TARGET_MIPS64', if_false: files(
+ 'mxu_translate.c',
+))
+
mips_ss.add(when: 'CONFIG_KVM', if_true: files('kvm.c'))
mips_softmmu_ss = ss.source_set()