aboutsummaryrefslogtreecommitdiff
path: root/target/mips/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé <f4bug@amsat.org>2020-11-29 22:24:40 +0100
committerPhilippe Mathieu-Daudé <f4bug@amsat.org>2021-01-14 17:13:53 +0100
commitc7a9ef75173f090616328d6870f71e8da2b6bd50 (patch)
treec8ff947fcff0722228df080d8fc38e6610b772a0 /target/mips/meson.build
parent878b87b54176d7cea4a74ec544703e408776ed34 (diff)
target/mips: Introduce decode tree bindings for MSA ASE
Introduce the 'msa32' decodetree config for the 32-bit MSA ASE. We start by decoding: - the branch instructions, - all instructions based on the MSA opcode. Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Message-Id: <20201215225757.764263-20-f4bug@amsat.org> Reviewed-by: Jiaxun Yang <jiaxun.yang@flygoat.com> Tested-by: Jiaxun Yang <jiaxun.yang@flygoat.com>
Diffstat (limited to 'target/mips/meson.build')
-rw-r--r--target/mips/meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/mips/meson.build b/target/mips/meson.build
index 2aa4d81300..a3c3724188 100644
--- a/target/mips/meson.build
+++ b/target/mips/meson.build
@@ -1,4 +1,9 @@
+gen = [
+ decodetree.process('msa32.decode', extra_args: '--static-decode=decode_msa32'),
+]
+
mips_ss = ss.source_set()
+mips_ss.add(gen)
mips_ss.add(files(
'cpu.c',
'gdbstub.c',