aboutsummaryrefslogtreecommitdiff
path: root/target/mips/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé <f4bug@amsat.org>2021-01-16 13:55:03 +0100
committerPhilippe Mathieu-Daudé <f4bug@amsat.org>2021-05-02 16:49:34 +0200
commit830a72301c35548907ff05399a99f34dab9c867d (patch)
tree1f44698a9fe597c04603cb47f92fefff92e2c827 /target/mips/meson.build
parent58ecf15d76e6e232d908bf115236108a639daa71 (diff)
target/mips: Move IEEE rounding mode array to new source file
restore_msa_fp_status() is declared inlined in fpu_helper.h, and uses the ieee_rm[] array. Therefore any code calling restore_msa_fp_status() must have access to this ieee_rm[] array. kvm_mips_get_fpu_registers(), which is in target/mips/kvm.c, calls restore_msa_fp_status. Except this tiny array, the rest of fpu_helper.c is only useful for the TCG accelerator. To be able to restrict fpu_helper.c to TCG, we need to move the ieee_rm[] array to a new source file. Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Message-Id: <20210428170410.479308-3-f4bug@amsat.org>
Diffstat (limited to 'target/mips/meson.build')
-rw-r--r--target/mips/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/mips/meson.build b/target/mips/meson.build
index 3733d1200f..5fcb211ca9 100644
--- a/target/mips/meson.build
+++ b/target/mips/meson.build
@@ -9,6 +9,7 @@ gen = [
mips_ss = ss.source_set()
mips_ss.add(files(
'cpu.c',
+ 'fpu.c',
'gdbstub.c',
))
mips_tcg_ss = ss.source_set()