aboutsummaryrefslogtreecommitdiff
path: root/target/mips/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé <f4bug@amsat.org>2020-12-08 18:59:36 +0100
committerPhilippe Mathieu-Daudé <f4bug@amsat.org>2021-01-14 17:13:53 +0100
commit5f21f30d8554b415142473fc4b58be42be193c46 (patch)
treef765820e0ae196f45ae97d391c02e5be3058c541 /target/mips/meson.build
parenta685f7d075a7ec09575cbb836cf07b64ae313e30 (diff)
target/mips: Introduce decodetree helpers for MSA LSA/DLSA opcodes
Add the LSA opcode to the MSA32 decodetree config, add DLSA to a new config for the MSA64 ASE, and call decode_msa64() in the main decode_opc() loop. Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Message-Id: <20201215225757.764263-23-f4bug@amsat.org>
Diffstat (limited to 'target/mips/meson.build')
-rw-r--r--target/mips/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/mips/meson.build b/target/mips/meson.build
index 3810554343..b63d8f150f 100644
--- a/target/mips/meson.build
+++ b/target/mips/meson.build
@@ -1,5 +1,6 @@
gen = [
decodetree.process('msa32.decode', extra_args: '--static-decode=decode_msa32'),
+ decodetree.process('msa64.decode', extra_args: '--static-decode=decode_msa64'),
]
mips_ss = ss.source_set()