aboutsummaryrefslogtreecommitdiff
path: root/system/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé <philmd@linaro.org>2023-10-04 11:06:28 +0200
committerPaolo Bonzini <pbonzini@redhat.com>2023-10-08 21:08:08 +0200
commit8d7f2e767d8cd058c817dbe31430b89f2e11535d (patch)
tree5b7c25cddf7e6c1b9dfc93c5169541e8c14e2901 /system/meson.build
parent01c85e60a4d0675f0ad203fe1fe119381e7ad15b (diff)
system: Rename softmmu/ directory as system/
The softmmu/ directory contains files specific to system emulation. Rename it as system/. Update meson rules, the MAINTAINERS file and all the documentation and comments. Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org> Message-ID: <20231004090629.37473-14-philmd@linaro.org> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'system/meson.build')
-rw-r--r--system/meson.build36
1 files changed, 36 insertions, 0 deletions
diff --git a/system/meson.build b/system/meson.build
new file mode 100644
index 0000000000..3a64dd89de
--- /dev/null
+++ b/system/meson.build
@@ -0,0 +1,36 @@
+specific_ss.add(when: 'CONFIG_SYSTEM_ONLY', if_true: [files(
+ 'arch_init.c',
+ 'ioport.c',
+ 'memory.c',
+ 'physmem.c',
+ 'watchpoint.c',
+)])
+
+system_ss.add(files(
+ 'balloon.c',
+ 'bootdevice.c',
+ 'cpus.c',
+ 'cpu-throttle.c',
+ 'cpu-timers.c',
+ 'datadir.c',
+ 'dirtylimit.c',
+ 'dma-helpers.c',
+ 'globals.c',
+ 'memory_mapping.c',
+ 'qdev-monitor.c',
+ 'qtest.c',
+ 'rtc.c',
+ 'runstate-action.c',
+ 'runstate-hmp-cmds.c',
+ 'runstate.c',
+ 'tpm-hmp-cmds.c',
+ 'vl.c',
+), sdl, libpmem, libdaxctl)
+
+if have_tpm
+ system_ss.add(files('tpm.c'))
+endif
+
+system_ss.add(when: seccomp, if_true: files('qemu-seccomp.c'))
+system_ss.add(when: fdt, if_true: files('device_tree.c'))
+system_ss.add(when: 'CONFIG_LINUX', if_true: files('async-teardown.c'))