aboutsummaryrefslogtreecommitdiff
path: root/subprojects/libvhost-user/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2020-11-25 14:06:39 +0400
committerMichael S. Tsirkin <mst@redhat.com>2020-12-09 13:04:17 -0500
commite0193568daf1785772c9d97a9825c401d463865f (patch)
treed79c71e39725aa0d4f687d2837c9d9a470108c6c /subprojects/libvhost-user/meson.build
parent0df750e9d3a5fea5e19f4750582121c9293a9d71 (diff)
libvhost-user: add a simple link test without glib
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Message-Id: <20201125100640.366523-8-marcandre.lureau@redhat.com> Reviewed-by: Michael S. Tsirkin <mst@redhat.com> Signed-off-by: Michael S. Tsirkin <mst@redhat.com>
Diffstat (limited to 'subprojects/libvhost-user/meson.build')
-rw-r--r--subprojects/libvhost-user/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/subprojects/libvhost-user/meson.build b/subprojects/libvhost-user/meson.build
index f9ecc534cf..c5d85c11d7 100644
--- a/subprojects/libvhost-user/meson.build
+++ b/subprojects/libvhost-user/meson.build
@@ -10,6 +10,10 @@ vhost_user = static_library('vhost-user',
include_directories: inc,
c_args: '-D_GNU_SOURCE')
+executable('link-test', files('link-test.c'),
+ link_whole: vhost_user,
+ include_directories: inc)
+
vhost_user_glib = static_library('vhost-user-glib',
files('libvhost-user-glib.c'),
include_directories: inc,