aboutsummaryrefslogtreecommitdiff
path: root/softmmu/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2020-10-06 09:01:22 +0200
committerPaolo Bonzini <pbonzini@redhat.com>2020-10-12 11:50:21 -0400
commit800d4deda04be016a95fbbf397c830a2d14ff9f6 (patch)
tree3079145f9804bb8c96deb3640fa51c5680ccae2a /softmmu/meson.build
parent8d0bceba24cc0917d9c6c5252d78db3d9fd5c58d (diff)
softmmu: move more files to softmmu/
Keep most softmmu_ss files into the system-emulation-specific directory. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'softmmu/meson.build')
-rw-r--r--softmmu/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/softmmu/meson.build b/softmmu/meson.build
index 36c96e7b15..862ab24878 100644
--- a/softmmu/meson.build
+++ b/softmmu/meson.build
@@ -14,3 +14,13 @@ specific_ss.add(when: 'CONFIG_SOFTMMU', if_true: [files(
specific_ss.add(when: ['CONFIG_SOFTMMU', 'CONFIG_TCG'], if_true: [files(
'icount.c'
)])
+
+softmmu_ss.add(files(
+ 'bootdevice.c',
+ 'dma-helpers.c',
+ 'qdev-monitor.c',
+), sdl)
+
+softmmu_ss.add(when: 'CONFIG_TPM', if_true: files('tpm.c'))
+softmmu_ss.add(when: 'CONFIG_SECCOMP', if_true: [files('qemu-seccomp.c'), seccomp])
+softmmu_ss.add(when: fdt, if_true: files('device_tree.c'))