aboutsummaryrefslogtreecommitdiff
path: root/semihosting/meson.build
diff options
context:
space:
mode:
authorRichard Henderson <richard.henderson@linaro.org>2022-04-28 01:44:28 -0700
committerRichard Henderson <richard.henderson@linaro.org>2022-06-28 04:35:39 +0530
commit5b3f39cb04fda32226e84502f858bab06d83e5c1 (patch)
tree3e5859fb0f4457ad96b21c76ff53503363fe61d1 /semihosting/meson.build
parent3753b00e5747068882c7f0302dcf9b87402993ab (diff)
semihosting: Split out semihost_sys_open
Split out the non-ARM specific portions of SYS_OPEN to a reusable function. This handles gdb and host file i/o. Add helpers to validate the length of the filename string. Prepare for usage by other semihosting by allowing the filename length parameter to be 0, and calling strlen. Reviewed-by: Luc Michel <lmichel@kalray.eu> Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
Diffstat (limited to 'semihosting/meson.build')
-rw-r--r--semihosting/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/semihosting/meson.build b/semihosting/meson.build
index d2c1c37bfd..8057db5494 100644
--- a/semihosting/meson.build
+++ b/semihosting/meson.build
@@ -1,5 +1,6 @@
specific_ss.add(when: 'CONFIG_SEMIHOSTING', if_true: files(
'guestfd.c',
+ 'syscalls.c',
))
specific_ss.add(when: ['CONFIG_SEMIHOSTING', 'CONFIG_SOFTMMU'], if_true: files(