aboutsummaryrefslogtreecommitdiff
path: root/python/setup.cfg
diff options
context:
space:
mode:
authorPeter Maydell <peter.maydell@linaro.org>2022-02-24 12:48:14 +0000
committerPeter Maydell <peter.maydell@linaro.org>2022-02-24 12:48:14 +0000
commitfa435db8ce1dff3b15e3f59a12f55f7b3a347b08 (patch)
tree0637100e8a0eb8e9f6c03ec95688adccd018be3a /python/setup.cfg
parent4aa2e497a98bafe962e72997f67a369e4b52d9c1 (diff)
parent89d38c74f4b69a93696392b55a9fee573055d78b (diff)
Merge remote-tracking branch 'remotes/jsnow-gitlab/tags/python-pull-request' into staging
Python patches New functionality in qmp-shell from Dan, and some packaging fixes. # gpg: Signature made Wed 23 Feb 2022 22:08:35 GMT # gpg: using RSA key F9B7ABDBBCACDF95BE76CBD07DEF8106AAFC390E # gpg: Good signature from "John Snow (John Huston) <jsnow@redhat.com>" [full] # Primary key fingerprint: FAEB 9711 A12C F475 812F 18F2 88A9 064D 1835 61EB # Subkey fingerprint: F9B7 ABDB BCAC DF95 BE76 CBD0 7DEF 8106 AAFC 390E * remotes/jsnow-gitlab/tags/python-pull-request: MAINTAINERS: python - remove ehabkost and add bleal Revert "python: pin setuptools below v60.0.0" Python: add setuptools v60.0 workaround Python: discourage direct setup.py install python: support recording QMP session to a file python: introduce qmp-shell-wrap convenience tool Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
Diffstat (limited to 'python/setup.cfg')
-rw-r--r--python/setup.cfg5
1 files changed, 4 insertions, 1 deletions
diff --git a/python/setup.cfg b/python/setup.cfg
index 18aea2bab3..241f243e8b 100644
--- a/python/setup.cfg
+++ b/python/setup.cfg
@@ -68,6 +68,7 @@ console_scripts =
qom-fuse = qemu.utils.qom_fuse:QOMFuse.entry_point [fuse]
qemu-ga-client = qemu.utils.qemu_ga_client:main
qmp-shell = qemu.aqmp.qmp_shell:main
+ qmp-shell-wrap = qemu.aqmp.qmp_shell:main_wrap
aqmp-tui = qemu.aqmp.aqmp_tui:main [tui]
[flake8]
@@ -113,7 +114,10 @@ ignore_missing_imports = True
# no Warning level messages displayed, use "--disable=all --enable=classes
# --disable=W".
disable=consider-using-f-string,
+ consider-using-with,
+ too-many-arguments,
too-many-function-args, # mypy handles this with less false positives.
+ too-many-instance-attributes,
no-member, # mypy also handles this better.
[pylint.basic]
@@ -163,7 +167,6 @@ deps =
.[devel]
.[fuse] # Workaround to trigger tox venv rebuild
.[tui] # Workaround to trigger tox venv rebuild
- setuptools < 60 # Workaround, please see commit msg.
commands =
make check