aboutsummaryrefslogtreecommitdiff
path: root/po/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2019-09-19 21:02:09 +0400
committerPaolo Bonzini <pbonzini@redhat.com>2020-08-21 06:30:45 -0400
commite8f3bd71d830f986c950439c0d125f4bab8e0313 (patch)
treeb13dc3dc73bc3dc2f2ffb2c846a7fa142070c191 /po/meson.build
parenta0b93237d82bed836842a75f9927ec72ebba280b (diff)
meson: convert po/
Meson warns if xgettext is not found. In the future we may want to add a required argument to i18n.gettext(); in the meanwhile, I am adding a --enable-gettext/--disable-gettext option and feature detection in configure. This preserves QEMU's default behavior of detecting system features, without any warning, if neither --enable-* nor --disable-* is requested. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'po/meson.build')
-rw-r--r--po/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/po/meson.build b/po/meson.build
new file mode 100644
index 0000000000..1387fd979a
--- /dev/null
+++ b/po/meson.build
@@ -0,0 +1,7 @@
+i18n = import('i18n')
+
+if get_option('gettext')
+ i18n.gettext(meson.project_name(),
+ args: '--msgid-bugs-address=qemu-devel@nongnu.org',
+ preset: 'glib')
+endif