aboutsummaryrefslogtreecommitdiff
path: root/pc-bios/meson.build
diff options
context:
space:
mode:
authorAkihiko Odaki <akihiko.odaki@gmail.com>2022-06-24 23:50:38 +0900
committerPaolo Bonzini <pbonzini@redhat.com>2022-07-13 16:58:57 +0200
commit882084a04ae9bec00e510a2319feba1d1a653fb1 (patch)
treec6ecb1cc33085e0eb6bf47e4deb7530a9fe36602 /pc-bios/meson.build
parentcf60ccc3306ca4726cbd286a156863863b00ff4f (diff)
datadir: Use bundle mechanism
softmmu/datadir.c had its own implementation to find files in the build tree, but now bundle mechanism provides the unified implementation which works for datadir and the other files. Signed-off-by: Akihiko Odaki <akihiko.odaki@gmail.com> Message-Id: <20220624145039.49929-4-akihiko.odaki@gmail.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'pc-bios/meson.build')
-rw-r--r--pc-bios/meson.build13
1 files changed, 3 insertions, 10 deletions
diff --git a/pc-bios/meson.build b/pc-bios/meson.build
index 41ba1c0ec7..388e0db6e4 100644
--- a/pc-bios/meson.build
+++ b/pc-bios/meson.build
@@ -85,16 +85,9 @@ blobs = [
'vof-nvram.bin',
]
-ln_s = [find_program('ln', required: true), '-sf']
-foreach f : blobs
- roms += custom_target(f,
- build_by_default: have_system,
- output: f,
- input: files('meson.build'), # dummy input
- install: get_option('install_blobs'),
- install_dir: qemu_datadir,
- command: [ ln_s, meson.project_source_root() / 'pc-bios' / f, '@OUTPUT@' ])
-endforeach
+if get_option('install_blobs')
+ install_data(blobs, install_dir: qemu_datadir)
+endif
subdir('descriptors')
subdir('keymaps')