aboutsummaryrefslogtreecommitdiff
path: root/migration/meson.build
diff options
context:
space:
mode:
authorJessica Clarke <jrtc27@jrtc27.com>2021-03-20 17:12:21 +0000
committerPaolo Bonzini <pbonzini@redhat.com>2021-04-01 09:40:45 +0200
commit76f67bac79f6d915c7760d46c2be58731def8f03 (patch)
tree48dd4b7f8a3fcddc75a0c847e49ee69d6c14c1a8 /migration/meson.build
parent6ee55e1d10c25c2f6bf5ce2084ad2327e17affa5 (diff)
meson: Propagate gnutls dependency to migration
Commit 3eacf70bb5a83e4775ad8003cbca63a40f70c8c2 neglected to fix this for softmmu configs, which pull in migration's use of gnutls. This fixes the following compilation failure on Arm-based Macs: In file included from migration/multifd.c:23: In file included from migration/tls.h:25: In file included from include/io/channel-tls.h:26: In file included from include/crypto/tlssession.h:24: include/crypto/tlscreds.h:28:10: fatal error: 'gnutls/gnutls.h' file not found #include <gnutls/gnutls.h> ^~~~~~~~~~~~~~~~~ 1 error generated. (as well as for channel.c and tls.c) Signed-off-by: Jessica Clarke <jrtc27@jrtc27.com> Reviewed-by: Juan Quintela <quintela@redhat.com> Message-Id: <20210320171221.37437-1-jrtc27@jrtc27.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'migration/meson.build')
-rw-r--r--migration/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/migration/meson.build b/migration/meson.build
index 9645f44005..6fa2f8745d 100644
--- a/migration/meson.build
+++ b/migration/meson.build
@@ -24,7 +24,7 @@ softmmu_ss.add(files(
'savevm.c',
'socket.c',
'tls.c',
-))
+), gnutls)
softmmu_ss.add(when: ['CONFIG_RDMA', rdma], if_true: files('rdma.c'))
softmmu_ss.add(when: 'CONFIG_LIVE_BLOCK_MIGRATION', if_true: files('block.c'))