aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé <philmd@linaro.org>2023-10-04 11:06:27 +0200
committerPaolo Bonzini <pbonzini@redhat.com>2023-10-07 19:03:07 +0200
commit01c85e60a4d0675f0ad203fe1fe119381e7ad15b (patch)
tree06aae0a2a421890b9b906b396fbbe4a25dbf2118 /meson.build
parent21d2140dd8a0e44cd24a640f0316d02e7927f603 (diff)
meson: Rename target_softmmu_arch -> target_system_arch
Finish the convertion started with commit de6cd7599b ("meson: Replace softmmu_ss -> system_ss"). If the $target_type is 'system', then use the target_system_arch[] source set :) Mechanical change doing: $ sed -i -e s/target_softmmu_arch/target_system_arch/g \ $(git grep -l target_softmmu_arch) Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org> Message-ID: <20231004090629.37473-13-philmd@linaro.org> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 54907c7fa9..167cb70956 100644
--- a/meson.build
+++ b/meson.build
@@ -3198,7 +3198,7 @@ modules = {}
target_modules = {}
hw_arch = {}
target_arch = {}
-target_softmmu_arch = {}
+target_system_arch = {}
target_user_arch = {}
###############
@@ -3718,7 +3718,7 @@ foreach target : target_dirs
endif
if target.endswith('-softmmu')
target_type='system'
- t = target_softmmu_arch[target_base_arch].apply(config_target, strict: false)
+ t = target_system_arch[target_base_arch].apply(config_target, strict: false)
arch_srcs += t.sources()
arch_deps += t.dependencies()