aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorStefano Stabellini <stefano.stabellini@amd.com>2023-06-14 17:03:36 -0700
committerStefano Stabellini <stefano.stabellini@amd.com>2023-06-15 16:46:42 -0700
commita4b4b40be86f69a994bf614edd49d8f1fb79422e (patch)
treef54d3b24a37a478237cb9071553806b47b6fd00d /meson.build
parent6c4193ed1690ab140a94d8288dcd41237504e7d2 (diff)
meson.build: do not set have_xen_pci_passthrough for aarch64 targets
have_xen_pci_passthrough is only used for Xen x86 VMs. Signed-off-by: Stefano Stabellini <stefano.stabellini@amd.com> Reviewed-by: Alex Bennée <alex.bennee@linaro.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 34306a6205..481865bfa9 100644
--- a/meson.build
+++ b/meson.build
@@ -1726,6 +1726,8 @@ have_xen_pci_passthrough = get_option('xen_pci_passthrough') \
error_message: 'Xen PCI passthrough requested but Xen not enabled') \
.require(targetos == 'linux',
error_message: 'Xen PCI passthrough not available on this platform') \
+ .require(cpu == 'x86' or cpu == 'x86_64',
+ error_message: 'Xen PCI passthrough not available on this platform') \
.allowed()