aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2022-04-20 17:33:34 +0200
committerPaolo Bonzini <pbonzini@redhat.com>2022-04-28 08:51:56 +0200
commitd065177e01d06800cdfd2919c9812ee53bd156bd (patch)
tree51cd59a3ebd63a6288880c007de68f7d61c73295 /meson.build
parentd1da229ff1333d4619e55bb5d99ba2e7a280d984 (diff)
meson: show final set of compiler flags
The actual set of compiler flags can grow beyond what is found by the configure script, for example if gprof is used. Show the full set in the summary. Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 0c38e491f4..9beca38ebb 100644
--- a/meson.build
+++ b/meson.build
@@ -3535,10 +3535,10 @@ link_args = get_option(link_language + '_link_args')
if link_args.length() > 0
summary_info += {'LDFLAGS': ' '.join(link_args)}
endif
-summary_info += {'QEMU_CFLAGS': config_host['QEMU_CFLAGS']}
-summary_info += {'QEMU_CXXFLAGS': config_host['QEMU_CXXFLAGS']}
-summary_info += {'QEMU_OBJCFLAGS': config_host['QEMU_OBJCFLAGS']}
-summary_info += {'QEMU_LDFLAGS': config_host['QEMU_LDFLAGS']}
+summary_info += {'QEMU_CFLAGS': ' '.join(qemu_cflags)}
+summary_info += {'QEMU_CXXFLAGS': ' '.join(qemu_cxxflags)}
+summary_info += {'QEMU_OBJCFLAGS': ' '.join(qemu_objcflags)}
+summary_info += {'QEMU_LDFLAGS': ' '.join(qemu_ldflags)}
summary_info += {'profiler': get_option('profiler')}
summary_info += {'link-time optimization (LTO)': get_option('b_lto')}
summary_info += {'PIE': get_option('b_pie')}