aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2024-03-20 11:28:28 +0100
committerPaolo Bonzini <pbonzini@redhat.com>2024-03-20 11:30:49 +0100
commit05007258f02da253af370387b69fe98e9f37b320 (patch)
tree35aa78f5b8ed13e838fe13fdd4b5c34382d222a9 /meson.build
parent732810235f8e7c0f7c961201d9d05b1f5c1ab5a5 (diff)
meson: remove dead dictionary access
The "link_depends" key has not been used since commit c46f76d1586 ("meson: specify fuzz linker script as a project arg", 2020-09-08), and even before that it was only used for fork-fuzzing which we removed in commit d2e6f9272d3 ("fuzz: remove fork-fuzzing scaffolding", 2023-02-16). So, remove it for a very small simplification of meson.build. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b375248a76..c9c3217ba4 100644
--- a/meson.build
+++ b/meson.build
@@ -3951,7 +3951,7 @@ foreach target : target_dirs
c_args: c_args,
dependencies: arch_deps + deps + exe['dependencies'],
objects: lib.extract_all_objects(recursive: true),
- link_depends: [block_syms, qemu_syms] + exe.get('link_depends', []),
+ link_depends: [block_syms, qemu_syms],
link_args: link_args,
win_subsystem: exe['win_subsystem'])