aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorVladimir Sementsov-Ogievskiy <vsementsov@yandex-team.ru>2023-04-21 12:27:58 +0300
committerKevin Wolf <kwolf@redhat.com>2023-05-10 14:15:13 +0200
commit11cea42e176bebc5e85866b01ade4a86651b7633 (patch)
treefcbe48952e0a32321b38c24269aab55331e5e5f4 /meson.build
parentb2896c1b09878fd1c4b485b3662f8beecbe0fef4 (diff)
block: add configure options for excluding vmdk, vhdx and vpc
Let's add --enable / --disable configure options for these formats, so that those who don't need them may not build them. Signed-off-by: Vladimir Sementsov-Ogievskiy <vsementsov@yandex-team.ru> Message-Id: <20230421092758.814122-1-vsementsov@yandex-team.ru> Reviewed-by: Kevin Wolf <kwolf@redhat.com> Signed-off-by: Kevin Wolf <kwolf@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 27782f8f52..c56e0fec9e 100644
--- a/meson.build
+++ b/meson.build
@@ -3929,6 +3929,9 @@ if have_block
summary_info += {'dmg support': get_option('dmg').allowed()}
summary_info += {'qcow v1 support': get_option('qcow1').allowed()}
summary_info += {'vdi support': get_option('vdi').allowed()}
+ summary_info += {'vhdx support': get_option('vhdx').allowed()}
+ summary_info += {'vmdk support': get_option('vmdk').allowed()}
+ summary_info += {'vpc support': get_option('vpc').allowed()}
summary_info += {'vvfat support': get_option('vvfat').allowed()}
summary_info += {'qed support': get_option('qed').allowed()}
summary_info += {'parallels support': get_option('parallels').allowed()}