aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Maydell <peter.maydell@linaro.org>2020-10-05 13:12:55 +0100
committerPeter Maydell <peter.maydell@linaro.org>2020-10-05 13:12:55 +0100
commit0ac0b47c44b4be6cbce26777a1a5968cc8f025a5 (patch)
tree02d95d3ad0efc145b0b84da900b09f62b017a184 /meson.build
parent671ad7c4468f795b66b4cd8f376f1b1ce6701b63 (diff)
parentd72d6dcb0d633bb08c2dc5a959a47608a1655018 (diff)
Merge remote-tracking branch 'remotes/bonzini-gitlab/tags/for-upstream' into staging
* move target configuration to default-configs/targets (myself) * Memory failure event (Zhenwei) # gpg: Signature made Mon 05 Oct 2020 08:14:29 BST # gpg: using RSA key F13338574B662389866C7682BFFBD25F78C7AE83 # gpg: issuer "pbonzini@redhat.com" # gpg: Good signature from "Paolo Bonzini <bonzini@gnu.org>" [full] # gpg: aka "Paolo Bonzini <pbonzini@redhat.com>" [full] # Primary key fingerprint: 46F5 9FBD 57D6 12E7 BFD4 E2F7 7E15 100C CD36 69B1 # Subkey fingerprint: F133 3857 4B66 2389 866C 7682 BFFB D25F 78C7 AE83 * remotes/bonzini-gitlab/tags/for-upstream: dockerfiles: add diffutils to Fedora tests: tcg: do not use implicit rules target-i386: post memory failure event to QMP qapi/run-state.json: introduce memory failure event target-i386: seperate MCIP & MCE_MASK error reason meson: move sparse detection to Meson and rewrite check_sparse.py default-configs: remove redundant keys default-configs: use TARGET_ARCH key configure: move OpenBSD W^X test to meson default-configs: remove default-configs/devices for user-mode targets configure: remove target configuration configure: remove useless config-target.mak symbols configure: compute derivatives of target name in meson configure: remove dead variable configure: move accelerator logic to meson configure: rewrite accelerator defaults as tests configure: convert accelerator variables to meson options default-configs: move files to default-configs/devices/ travis: remove TCI test Signed-off-by: Peter Maydell <peter.maydell@linaro.org> # Conflicts: # configure
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build190
1 files changed, 164 insertions, 26 deletions
diff --git a/meson.build b/meson.build
index 20f6ad774a..a02c743794 100644
--- a/meson.build
+++ b/meson.build
@@ -51,6 +51,28 @@ configure_file(input: files('scripts/ninjatool.py'),
output: 'ninjatool',
configuration: config_host)
+if cpu in ['x86', 'x86_64']
+ kvm_targets = ['i386-softmmu', 'x86_64-softmmu']
+elif cpu == 'aarch64'
+ kvm_targets = ['aarch64-softmmu']
+elif cpu == 's390x'
+ kvm_targets = ['s390x-softmmu']
+elif cpu in ['ppc', 'ppc64']
+ kvm_targets = ['ppc-softmmu', 'ppc64-softmmu']
+else
+ kvm_targets = []
+endif
+
+accelerator_targets = { 'CONFIG_KVM': kvm_targets }
+if cpu in ['x86', 'x86_64']
+ accelerator_targets += {
+ 'CONFIG_HAX': ['i386-softmmu', 'x86_64-softmmu'],
+ 'CONFIG_XEN': ['i386-softmmu', 'x86_64-softmmu'],
+ 'CONFIG_HVF': ['x86_64-softmmu'],
+ 'CONFIG_WHPX': ['i386-softmmu', 'x86_64-softmmu'],
+ }
+endif
+
##################
# Compiler flags #
##################
@@ -81,11 +103,13 @@ if host_machine.system() == 'darwin'
add_languages('objc', required: false, native: false)
endif
-if 'SPARSE_CFLAGS' in config_host
+sparse = find_program('cgcc', required: get_option('sparse'))
+if sparse.found()
run_target('sparse',
command: [find_program('scripts/check_sparse.py'),
- config_host['SPARSE_CFLAGS'].split(),
- 'compile_commands.json'])
+ 'compile_commands.json', sparse.full_path(), '-Wbitwise',
+ '-Wno-transparent-union', '-Wno-old-initializer',
+ '-Wno-non-pointer-null'])
endif
###########################################
@@ -103,8 +127,9 @@ socket = []
version_res = []
coref = []
iokit = []
+emulator_link_args = []
cocoa = not_found
-hvf = []
+hvf = not_found
if targetos == 'windows'
socket = cc.find_library('ws2_32')
winmm = cc.find_library('winmm')
@@ -117,7 +142,6 @@ elif targetos == 'darwin'
coref = dependency('appleframeworks', modules: 'CoreFoundation')
iokit = dependency('appleframeworks', modules: 'IOKit')
cocoa = dependency('appleframeworks', modules: 'Cocoa', required: get_option('cocoa'))
- hvf = dependency('appleframeworks', modules: 'Hypervisor')
elif targetos == 'sunos'
socket = [cc.find_library('socket'),
cc.find_library('nsl'),
@@ -126,8 +150,71 @@ elif targetos == 'haiku'
socket = [cc.find_library('posix_error_mapper'),
cc.find_library('network'),
cc.find_library('bsd')]
+elif targetos == 'openbsd'
+ if not get_option('tcg').disabled() and target_dirs.length() > 0
+ # Disable OpenBSD W^X if available
+ emulator_link_args = cc.get_supported_link_arguments('-Wl,-z,wxneeded')
+ endif
endif
+accelerators = []
+if not get_option('kvm').disabled() and targetos == 'linux'
+ accelerators += 'CONFIG_KVM'
+endif
+if not get_option('xen').disabled() and 'CONFIG_XEN_BACKEND' in config_host
+ accelerators += 'CONFIG_XEN'
+ have_xen_pci_passthrough = not get_option('xen_pci_passthrough').disabled() and targetos == 'linux'
+else
+ have_xen_pci_passthrough = false
+endif
+if not get_option('whpx').disabled() and targetos == 'windows'
+ if get_option('whpx').enabled() and cpu != 'x86_64'
+ error('WHPX requires 64-bit host')
+ elif cc.has_header('WinHvPlatform.h', required: get_option('whpx')) and \
+ cc.has_header('WinHvEmulation.h', required: get_option('whpx'))
+ accelerators += 'CONFIG_WHPX'
+ endif
+endif
+if not get_option('hvf').disabled()
+ hvf = dependency('appleframeworks', modules: 'Hypervisor',
+ required: get_option('hvf'))
+ if hvf.found()
+ accelerators += 'CONFIG_HVF'
+ endif
+endif
+if not get_option('hax').disabled()
+ if get_option('hax').enabled() or targetos in ['windows', 'darwin', 'netbsd']
+ accelerators += 'CONFIG_HAX'
+ endif
+endif
+if not get_option('tcg').disabled()
+ if cpu not in supported_cpus
+ if 'CONFIG_TCG_INTERPRETER' in config_host
+ warning('Unsupported CPU @0@, will use TCG with TCI (experimental)'.format(cpu))
+ else
+ error('Unsupported CPU @0@, try --enable-tcg-interpreter'.format(cpu))
+ endif
+ endif
+ accelerators += 'CONFIG_TCG'
+ config_host += { 'CONFIG_TCG': 'y' }
+endif
+
+if 'CONFIG_KVM' not in accelerators and get_option('kvm').enabled()
+ error('KVM not available on this platform')
+endif
+if 'CONFIG_HVF' not in accelerators and get_option('hvf').enabled()
+ error('HVF not available on this platform')
+endif
+if 'CONFIG_WHPX' not in accelerators and get_option('whpx').enabled()
+ error('WHPX not available on this platform')
+endif
+if not have_xen_pci_passthrough and get_option('xen_pci_passthrough').enabled()
+ if 'CONFIG_XEN' in accelerators
+ error('Xen PCI passthrough not available on this platform')
+ else
+ error('Xen PCI passthrough requested but Xen not enabled')
+ endif
+endif
if not cocoa.found() and get_option('cocoa').enabled()
error('Cocoa not available on this platform')
endif
@@ -556,12 +643,15 @@ config_host_data.set('QEMU_VERSION_MAJOR', meson.project_version().split('.')[0]
config_host_data.set('QEMU_VERSION_MINOR', meson.project_version().split('.')[1])
config_host_data.set('QEMU_VERSION_MICRO', meson.project_version().split('.')[2])
+ignored = ['CONFIG_QEMU_INTERP_PREFIX'] # actually per-target
arrays = ['CONFIG_AUDIO_DRIVERS', 'CONFIG_BDRV_RW_WHITELIST', 'CONFIG_BDRV_RO_WHITELIST']
strings = ['HOST_DSOSUF', 'CONFIG_IASL', 'bindir', 'prefix', 'qemu_confdir', 'qemu_datadir',
'qemu_moddir', 'qemu_localstatedir', 'qemu_helperdir', 'qemu_localedir',
'qemu_icondir', 'qemu_desktopdir', 'qemu_firmwarepath', 'sysconfdir']
foreach k, v: config_host
- if arrays.contains(k)
+ if ignored.contains(k)
+ # do nothing
+ elif arrays.contains(k)
if v != ''
v = '"' + '", "'.join(v.split()) + '", '
endif
@@ -634,18 +724,68 @@ kconfig_external_symbols = [
'CONFIG_LINUX',
'CONFIG_PVRDMA',
]
-ignored = ['TARGET_XML_FILES', 'TARGET_ABI_DIR', 'TARGET_DIRS']
-
-accel_symbols = [
- 'CONFIG_KVM',
- 'CONFIG_HAX',
- 'CONFIG_HVF',
- 'CONFIG_TCG',
- 'CONFIG_WHPX'
-]
+ignored = [ 'TARGET_XML_FILES', 'TARGET_ABI_DIR', 'TARGET_ARCH' ]
+default_targets = 'CONFIG_DEFAULT_TARGETS' in config_host
+actual_target_dirs = []
foreach target : target_dirs
- config_target = keyval.load(meson.current_build_dir() / target / 'config-target.mak')
+ config_target = { 'TARGET_NAME': target.split('-')[0] }
+ if target.endswith('linux-user')
+ if targetos != 'linux'
+ if default_targets
+ continue
+ endif
+ error('Target @0@ is only available on a Linux host'.format(target))
+ endif
+ config_target += { 'CONFIG_LINUX_USER': 'y' }
+ elif target.endswith('bsd-user')
+ if 'CONFIG_BSD' not in config_host
+ if default_targets
+ continue
+ endif
+ error('Target @0@ is only available on a BSD host'.format(target))
+ endif
+ config_target += { 'CONFIG_BSD_USER': 'y' }
+ elif target.endswith('softmmu')
+ config_target += { 'CONFIG_SOFTMMU': 'y' }
+ endif
+ if target.endswith('-user')
+ config_target += {
+ 'CONFIG_USER_ONLY': 'y',
+ 'CONFIG_QEMU_INTERP_PREFIX':
+ config_host['CONFIG_QEMU_INTERP_PREFIX'].format(config_target['TARGET_NAME'])
+ }
+ endif
+
+ have_accel = false
+ foreach sym: accelerators
+ if sym == 'CONFIG_TCG' or target in accelerator_targets.get(sym, [])
+ config_target += { sym: 'y' }
+ config_all += { sym: 'y' }
+ if sym == 'CONFIG_XEN' and have_xen_pci_passthrough
+ config_target += { 'CONFIG_XEN_PCI_PASSTHROUGH': 'y' }
+ endif
+ have_accel = true
+ endif
+ endforeach
+ if not have_accel
+ if default_targets
+ continue
+ endif
+ error('No accelerator available for target @0@'.format(target))
+ endif
+
+ actual_target_dirs += target
+ config_target += keyval.load('default-configs/targets' / target + '.mak')
+ config_target += { 'TARGET_' + config_target['TARGET_ARCH'].to_upper(): 'y' }
+
+ # Add default keys
+ if 'TARGET_BASE_ARCH' not in config_target
+ config_target += {'TARGET_BASE_ARCH': config_target['TARGET_ARCH']}
+ endif
+ if 'TARGET_ABI_DIR' not in config_target
+ config_target += {'TARGET_ABI_DIR': config_target['TARGET_ARCH']}
+ endif
foreach k, v: disassemblers
if config_host['ARCH'].startswith(k) or config_target['TARGET_BASE_ARCH'].startswith(k)
@@ -663,8 +803,10 @@ foreach target : target_dirs
elif ignored.contains(k)
# do nothing
elif k == 'TARGET_BASE_ARCH'
+ # Note that TARGET_BASE_ARCH ends up in config-target.h but it is
+ # not used to select files from sourcesets.
config_target_data.set('TARGET_' + v.to_upper(), 1)
- elif k == 'TARGET_NAME'
+ elif k == 'TARGET_NAME' or k == 'CONFIG_QEMU_INTERP_PREFIX'
config_target_data.set_quoted(k, v)
elif v == 'y'
config_target_data.set(k, 1)
@@ -672,11 +814,6 @@ foreach target : target_dirs
config_target_data.set(k, v)
endif
endforeach
- foreach sym: accel_symbols
- if config_target.has_key(sym)
- config_all += { sym: 'y' }
- endif
- endforeach
config_target_h += {target: configure_file(output: target + '-config-target.h',
configuration: config_target_data)}
@@ -690,7 +827,7 @@ foreach target : target_dirs
config_devices_mak = target + '-config-devices.mak'
config_devices_mak = configure_file(
- input: ['default-configs' / target + '.mak', 'Kconfig'],
+ input: ['default-configs/devices' / target + '.mak', 'Kconfig'],
output: config_devices_mak,
depfile: config_devices_mak + '.d',
capture: true,
@@ -711,6 +848,7 @@ foreach target : target_dirs
endif
config_target_mak += {target: config_target}
endforeach
+target_dirs = actual_target_dirs
# This configuration is used to build files that are shared by
# multiple binaries, and then extracted out of the "common"
@@ -1237,7 +1375,7 @@ foreach target : target_dirs
c_args = ['-DNEED_CPU_H',
'-DCONFIG_TARGET="@0@-config-target.h"'.format(target),
'-DCONFIG_DEVICES="@0@-config-devices.h"'.format(target)]
- link_args = []
+ link_args = emulator_link_args
config_target += config_host
target_inc = [include_directories('target' / config_target['TARGET_BASE_ARCH'])]
@@ -1528,9 +1666,9 @@ if config_host.has_key('CONFIG_MODULES')
endif
summary_info += {'host CPU': cpu}
summary_info += {'host endianness': build_machine.endian()}
-summary_info += {'target list': config_host['TARGET_DIRS']}
+summary_info += {'target list': ' '.join(target_dirs)}
summary_info += {'gprof enabled': config_host.has_key('CONFIG_GPROF')}
-summary_info += {'sparse enabled': meson.get_compiler('c').cmd_array().contains('cgcc')}
+summary_info += {'sparse enabled': sparse.found()}
summary_info += {'strip binaries': get_option('strip')}
summary_info += {'profiler': config_host.has_key('CONFIG_PROFILER')}
summary_info += {'static build': config_host.has_key('CONFIG_STATIC')}