aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorWarner Losh <imp@bsdimp.com>2021-11-04 16:34:48 -0600
committerWarner Losh <imp@bsdimp.com>2022-01-07 22:58:51 -0700
commit19bf129f8245a0f53130cb368ef616a0c362b8f4 (patch)
tree6f17301ddac65bb7b18e44f2e4913f36d24d122a /meson.build
parentaa3a2428308fe6831ce4b2f9d28ff8572b74f6c4 (diff)
bsd-user: create a per-arch signal.c file
Create a place-holder signal.c file for each of the architectures that are currently built. In the future, some code that's currently inlined in target_arch_signal.h will live here. Signed-off-by: Warner Losh <imp@bsdimp.com> Reviewed-by: Richard Henderson <richard.henderson@linaro.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 53065e96ec..c1b1db1e28 100644
--- a/meson.build
+++ b/meson.build
@@ -2933,7 +2933,7 @@ foreach target : target_dirs
base_dir = 'bsd-user'
target_inc += include_directories('bsd-user/' / targetos)
dir = base_dir / abi
- arch_srcs += files(dir / 'target_arch_cpu.c')
+ arch_srcs += files(dir / 'signal.c', dir / 'target_arch_cpu.c')
endif
target_inc += include_directories(
base_dir,