aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2019-07-15 22:54:34 +0400
committerPaolo Bonzini <pbonzini@redhat.com>2020-08-21 06:30:15 -0400
commit5e7fbd25157342b3b983779939419fb328e00f4c (patch)
treebb60d53304fbf9df16eef6febe4f9b2055f31b5c /meson.build
parentde59dda32db56a0126047f74ec817df181f22f4a (diff)
meson: convert authz directory to Meson
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 658d45c4c6..34363bff19 100644
--- a/meson.build
+++ b/meson.build
@@ -103,6 +103,10 @@ if 'CONFIG_GNUTLS' in config_host
endif
pixman = declare_dependency(compile_args: config_host['PIXMAN_CFLAGS'].split(),
link_args: config_host['PIXMAN_LIBS'].split())
+pam = not_found
+if 'CONFIG_AUTH_PAM' in config_host
+ pam = cc.find_library('pam')
+endif
libattr = not_found
if 'CONFIG_ATTR' in config_host
libattr = declare_dependency(link_args: config_host['LIBATTR_LIBS'].split())
@@ -341,6 +345,7 @@ qemuutil = declare_dependency(link_with: libqemuutil,
sources: genh + version_res)
subdir('qom')
+subdir('authz')
subdir('fsdev')
# Other build targets