aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Huth <thuth@redhat.com>2021-07-13 11:31:53 +0200
committerPaolo Bonzini <pbonzini@redhat.com>2021-07-22 14:44:51 +0200
commit3a6a1256d46daa21210d52b2740121f4ea929e9b (patch)
tree5a0457575057e899fa0352a476d48ad82a3debb7 /meson.build
parent332008e0b9da33dee2c765db3e4e16b3c3ba3a92 (diff)
configure: Allow vnc to get disabled with --without-default-features
There's no reason why we should keep VNC enabled when the user specified --without-default-features. Reported-by: Cole Robinson <crobinso@redhat.com> Signed-off-by: Thomas Huth <thuth@redhat.com> Message-Id: <20210713093155.677589-3-thuth@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index eb85fe8e44..cb3856fc35 100644
--- a/meson.build
+++ b/meson.build
@@ -930,7 +930,7 @@ vnc = not_found
png = not_found
jpeg = not_found
sasl = not_found
-if get_option('vnc').enabled()
+if not get_option('vnc').disabled()
vnc = declare_dependency() # dummy dependency
png = dependency('libpng', required: get_option('vnc_png'),
method: 'pkg-config', kwargs: static_kwargs)