aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2019-07-15 14:39:25 +0400
committerPaolo Bonzini <pbonzini@redhat.com>2020-08-21 06:30:13 -0400
commit8f51e01c0141659435318c41af6e37402f3eb2de (patch)
tree642e2369a5a2f5722c704b202f840abe9c71cab5 /meson.build
parent588a19fa9d41656b2e27a20153bc75f12ddf1194 (diff)
meson: add qemu-bridge-helper
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 5cd8ee0298..3568b4816e 100644
--- a/meson.build
+++ b/meson.build
@@ -297,7 +297,6 @@ qemuutil = declare_dependency(link_with: libqemuutil,
sources: genh + version_res)
# Other build targets
-
if 'CONFIG_GUEST_AGENT' in config_host
subdir('qga')
endif
@@ -315,6 +314,14 @@ if have_tools
subdir('contrib/vhost-user-input')
subdir('contrib/vhost-user-scsi')
endif
+
+ if targetos == 'linux'
+ executable('qemu-bridge-helper', files('qemu-bridge-helper.c'),
+ dependencies: [qemuutil, libcap_ng],
+ install: true,
+ install_dir: get_option('libexecdir'))
+ endif
+
if 'CONFIG_IVSHMEM' in config_host
subdir('contrib/ivshmem-client')
subdir('contrib/ivshmem-server')