aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorRichard Henderson <richard.henderson@linaro.org>2021-11-16 17:26:43 +0100
committerRichard Henderson <richard.henderson@linaro.org>2021-11-16 17:26:43 +0100
commit9104bd89dadd0b17c414ba24b0841d0042179a2e (patch)
treee58f7aa8b05862f87fa6002ff7054901270ba06b /meson.build
parent871c71b1bad2d2647641500603a2236869135c7f (diff)
parent9968de0a4a5470bd7b98dcd2fae5d5269908f16b (diff)
Merge tag 'pull-for-6.2-161121-1' of https://github.com/stsquad/qemu into staging
Misc build and test fixes: - force NOUSER for base docker images - don't run TCG VM tests by default - remove useless meson test - add Centos 8 custom runner - split up custom-runners to individual files - skip cirrus checks on master/stable branches # gpg: Signature made Tue 16 Nov 2021 05:22:09 PM CET # gpg: using RSA key 6685AE99E75167BCAFC8DF35FBD0DB095A9E2A44 # gpg: Good signature from "Alex Bennée (Master Work Key) <alex.bennee@linaro.org>" [full] * tag 'pull-for-6.2-161121-1' of https://github.com/stsquad/qemu: gitlab: skip cirrus jobs on master and stable branches gitlab-ci: Split custom-runners.yml in one file per runner Jobs based on custom runners: add CentOS Stream 8 meson: remove useless libdl test tests/vm: don't build using TCG by default tests/vm: sort the special variable list tests/docker: force NOUSER=1 for base images Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 1 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index 2ece4fe088..baeaee4522 100644
--- a/meson.build
+++ b/meson.build
@@ -566,13 +566,7 @@ endif
spice_headers = spice.partial_dependency(compile_args: true, includes: true)
rt = cc.find_library('rt', required: false)
-libdl = not_found
-if 'CONFIG_PLUGIN' in config_host
- libdl = cc.find_library('dl', required: false)
- if not cc.has_function('dlopen', dependencies: libdl)
- error('dlopen not found')
- endif
-endif
+
libiscsi = not_found
if not get_option('libiscsi').auto() or have_block
libiscsi = dependency('libiscsi', version: '>=1.9.0',