aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2023-03-30 12:47:23 +0200
committerPaolo Bonzini <pbonzini@redhat.com>2023-05-18 08:53:52 +0200
commit5328353c05d880fbdba16a968cf9a39c8bd11a14 (patch)
tree92f4ede5717ad5bba30a905dd4704f33d9dfbeb5 /meson.build
parentbd3615d68fabb3578467e34af345c3eb8d88a0b2 (diff)
meson: drop unnecessary declare_dependency()
The libvfio_user_dep variable of subprojects/libvfio-user/lib/meson.build is already a dependency, so there is no need to wrap it with another declare_dependency(). Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 3262d4daa3..5678551cd0 100644
--- a/meson.build
+++ b/meson.build
@@ -2741,9 +2741,7 @@ if have_system and vfio_user_server_allowed
libvfio_user_proj = subproject('libvfio-user')
- libvfio_user_lib = libvfio_user_proj.get_variable('libvfio_user_dep')
-
- libvfio_user_dep = declare_dependency(dependencies: [libvfio_user_lib])
+ libvfio_user_dep = libvfio_user_proj.get_variable('libvfio_user_dep')
endif
fdt = not_found