aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorYonggang Luo <luoyonggang@gmail.com>2020-08-26 23:10:03 +0800
committerPaolo Bonzini <pbonzini@redhat.com>2020-08-27 18:52:30 +0200
commit363743dacb5e6b0949dd2bc305bafc9594d2c799 (patch)
tree69035900e6da2e39b2c0d72d8aa374d939d2c037 /meson.build
parentcb23fd474035f7232a462dbcad8e61e6b1fa12f1 (diff)
meson: Mingw64 gcc doesn't recognize system include_type for sdl2
Windows paths result in command lines like "-isystemC:/msys64/..." that are not recognized by GCC. "include_type: 'system'" was only included in an attempt to fix the -Wundef warnings in SDL 2.0.8, but it was not effective. Therefore we can fix this by remove the include_type. Signed-off-by: Yonggang Luo <luoyonggang@gmail.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 90128616e5..e6aa44be54 100644
--- a/meson.build
+++ b/meson.build
@@ -240,8 +240,7 @@ endif
sdl = not_found
if have_system
- sdl = dependency('sdl2', required: get_option('sdl'), static: enable_static,
- include_type: 'system')
+ sdl = dependency('sdl2', required: get_option('sdl'), static: enable_static)
sdl_image = not_found
endif
if sdl.found()