aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDaniel P. Berrangé <berrange@redhat.com>2023-09-21 10:12:51 +0100
committerDaniel P. Berrangé <berrange@redhat.com>2024-02-09 12:47:50 +0000
commitfdd51403a35a484f29c405c3d5cb0058f80bd3ba (patch)
tree9ecf9ae787def1abf634d43df42945a503c4eff7 /meson.build
parent9e34f127f419b3941b36dfdfac79640dc81e97e2 (diff)
meson: sort C warning flags alphabetically
When scanning the list of warning flags to see if one is present, it is helpful if they are in alphabetical order. It is further helpful to separate out the 'no-' prefixed warnings. Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org> Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build40
1 files changed, 21 insertions, 19 deletions
diff --git a/meson.build b/meson.build
index e5d6f2d057..74d3aa0b12 100644
--- a/meson.build
+++ b/meson.build
@@ -571,36 +571,38 @@ qemu_common_flags += cc.get_supported_arguments(hardening_flags)
add_global_arguments(qemu_common_flags, native: false, language: all_languages)
add_global_link_arguments(qemu_ldflags, native: false, language: all_languages)
-# Collect warnings that we want to enable
-
+# Collect warning flags we want to set, sorted alphabetically
warn_flags = [
- '-Wundef',
- '-Wwrite-strings',
- '-Wmissing-prototypes',
- '-Wstrict-prototypes',
- '-Wredundant-decls',
- '-Wold-style-declaration',
- '-Wold-style-definition',
- '-Wtype-limits',
- '-Wformat-security',
- '-Wformat-y2k',
- '-Winit-self',
- '-Wignored-qualifiers',
+ # First enable interesting warnings
'-Wempty-body',
- '-Wnested-externs',
'-Wendif-labels',
'-Wexpansion-to-defined',
+ '-Wformat-security',
+ '-Wformat-y2k',
+ '-Wignored-qualifiers',
'-Wimplicit-fallthrough=2',
+ '-Winit-self',
'-Wmissing-format-attribute',
+ '-Wmissing-prototypes',
+ '-Wnested-externs',
+ '-Wold-style-declaration',
+ '-Wold-style-definition',
+ '-Wredundant-decls',
+ '-Wshadow=local',
+ '-Wstrict-prototypes',
+ '-Wtype-limits',
+ '-Wundef',
+ '-Wwrite-strings',
+
+ # Then disable some undesirable warnings
+ '-Wno-gnu-variable-sized-type-not-at-end',
'-Wno-initializer-overrides',
'-Wno-missing-include-dirs',
+ '-Wno-psabi',
'-Wno-shift-negative-value',
'-Wno-string-plus-int',
- '-Wno-typedef-redefinition',
'-Wno-tautological-type-limit-compare',
- '-Wno-psabi',
- '-Wno-gnu-variable-sized-type-not-at-end',
- '-Wshadow=local',
+ '-Wno-typedef-redefinition',
]
if host_os != 'darwin'