aboutsummaryrefslogtreecommitdiff
path: root/linux-user/meson.build
diff options
context:
space:
mode:
authorRichard Henderson <richard.henderson@linaro.org>2021-11-17 16:14:00 +0100
committerRichard Henderson <richard.henderson@linaro.org>2021-12-20 10:12:24 -0800
commitbbf15aaf7c7506c88062288b3ae122b882f65e69 (patch)
tree35c44f9cb40a66389e85da8afbb4fd65efc71af2 /linux-user/meson.build
parent2ac16d01e371ba9fb268f04249eaca9fafceb00b (diff)
common-user: Move safe-syscall.* from linux-user
Move linux-user safe-syscall.S and safe-syscall-error.c to common-user so that bsd-user can also use it. Also move safe-syscall.h to include/user/. Since there is nothing here that is related to the guest, as opposed to the host, build it once. Reviewed-by: Warner Losh <imp@bsdimp.com> Reviewed-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
Diffstat (limited to 'linux-user/meson.build')
-rw-r--r--linux-user/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/linux-user/meson.build b/linux-user/meson.build
index 94ac3c58ce..eef1dd68bd 100644
--- a/linux-user/meson.build
+++ b/linux-user/meson.build
@@ -2,6 +2,9 @@ if not have_linux_user
subdir_done()
endif
+common_user_inc += include_directories('host/' / host_arch)
+common_user_inc += include_directories('.')
+
linux_user_ss.add(files(
'elfload.c',
'exit.c',
@@ -9,8 +12,6 @@ linux_user_ss.add(files(
'linuxload.c',
'main.c',
'mmap.c',
- 'safe-syscall.S',
- 'safe-syscall-error.c',
'signal.c',
'strace.c',
'syscall.c',