aboutsummaryrefslogtreecommitdiff
path: root/hw/virtio/meson.build
diff options
context:
space:
mode:
authorMathieu Poirier <mathieu.poirier@linaro.org>2021-10-12 14:59:03 -0600
committerMichael S. Tsirkin <mst@redhat.com>2021-10-20 04:37:55 -0400
commitc7160fff7d48cead5d673ef2032b60c363c84e27 (patch)
tree352372c07b403a213bb396bb852d5e00ad1b143f /hw/virtio/meson.build
parent821d28b88f850e5fbc66ee62bdd155eb2d474a29 (diff)
vhost-user-rng-pci: Add vhost-user-rng-pci implementation
This patch provides a PCI bus interface to the vhost-user-rng backend. Reviewed-by: Alex Bennée <alex.bennee@linaro.org> Signed-off-by: Mathieu Poirier <mathieu.poirier@linaro.org> Message-Id: <20211012205904.4106769-3-mathieu.poirier@linaro.org> Reviewed-by: Michael S. Tsirkin <mst@redhat.com> Signed-off-by: Michael S. Tsirkin <mst@redhat.com>
Diffstat (limited to 'hw/virtio/meson.build')
-rw-r--r--hw/virtio/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/hw/virtio/meson.build b/hw/virtio/meson.build
index ae6b2cde10..521f7d64a8 100644
--- a/hw/virtio/meson.build
+++ b/hw/virtio/meson.build
@@ -28,6 +28,7 @@ virtio_ss.add(when: 'CONFIG_VIRTIO_MEM', if_true: files('virtio-mem.c'))
virtio_ss.add(when: 'CONFIG_VHOST_USER_I2C', if_true: files('vhost-user-i2c.c'))
virtio_ss.add(when: ['CONFIG_VIRTIO_PCI', 'CONFIG_VHOST_USER_I2C'], if_true: files('vhost-user-i2c-pci.c'))
virtio_ss.add(when: 'CONFIG_VHOST_USER_RNG', if_true: files('vhost-user-rng.c'))
+virtio_ss.add(when: ['CONFIG_VHOST_USER_RNG', 'CONFIG_VIRTIO_PCI'], if_true: files('vhost-user-rng-pci.c'))
virtio_pci_ss = ss.source_set()
virtio_pci_ss.add(when: 'CONFIG_VHOST_VSOCK', if_true: files('vhost-vsock-pci.c'))