aboutsummaryrefslogtreecommitdiff
path: root/hw/usb/meson.build
diff options
context:
space:
mode:
authorHongren (Zenithal) Zheng <i@zenithal.me>2022-05-19 20:38:57 +0800
committerGerd Hoffmann <kraxel@redhat.com>2022-06-14 10:34:36 +0200
commit8caef8507809634fc70ecb1faa898a0edaf1ae5c (patch)
tree636d7d4dbebb1a4fa08c3ab76ff7d78002a0acea /hw/usb/meson.build
parentd37d0e0e855222b89008930b8675198ce74f8d4f (diff)
meson: Add CanoKey
Signed-off-by: Hongren (Zenithal) Zheng <i@zenithal.me> Message-Id: <YoY6YRD6cxH21mms@Sun> Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
Diffstat (limited to 'hw/usb/meson.build')
-rw-r--r--hw/usb/meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/hw/usb/meson.build b/hw/usb/meson.build
index de853d780d..793df42e21 100644
--- a/hw/usb/meson.build
+++ b/hw/usb/meson.build
@@ -63,6 +63,11 @@ if u2f.found()
softmmu_ss.add(when: 'CONFIG_USB_U2F', if_true: [u2f, files('u2f-emulated.c')])
endif
+# CanoKey
+if canokey.found()
+ softmmu_ss.add(when: 'CONFIG_USB_CANOKEY', if_true: [canokey, files('canokey.c')])
+endif
+
# usb redirect
if usbredir.found()
usbredir_ss = ss.source_set()