aboutsummaryrefslogtreecommitdiff
path: root/hw/usb/meson.build
diff options
context:
space:
mode:
authorGerd Hoffmann <kraxel@redhat.com>2021-01-19 20:44:51 +0100
committerGerd Hoffmann <kraxel@redhat.com>2021-01-22 14:51:35 +0100
commit0f6dba145a4be998e0e5e4ccd94d9df8609eb327 (patch)
treee9b82396f97243e698446634dbc65ac83089da48 /hw/usb/meson.build
parentd755cb9696e8aa16e850ac5f0b908015520cd395 (diff)
usb: add pcap support.
Log all traffic of a specific usb device to a pcap file for later inspection. File format is compatible with linux usb monitor. Usage: qemu -device usb-${somedevice},pcap=file.pcap wireshark file.pcap Signed-off-by: Gerd Hoffmann <kraxel@redhat.com> Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com> Message-Id: <20210119194452.2148048-1-kraxel@redhat.com> Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
Diffstat (limited to 'hw/usb/meson.build')
-rw-r--r--hw/usb/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/hw/usb/meson.build b/hw/usb/meson.build
index f46c6b6655..653192cff6 100644
--- a/hw/usb/meson.build
+++ b/hw/usb/meson.build
@@ -5,6 +5,7 @@ softmmu_ss.add(files(
'bus.c',
'combined-packet.c',
'core.c',
+ 'pcap.c',
'libhw.c'
))